Re: Web Server Help?

My new server I’m configuring screwed up after about 90% of sites were moved.
It’s Ubuntu 6.10 with apache2
Everything worked fine, then all of a sudden the virtual sites stopped working and all requests go to the root /var/www folder instead of the /var/www/sitename/web/ folders as directed.
Everything looks ok
the /etc/apache2/sites-available files
and the links in

the only clue /etc/init.d/apache2 restart gives:     
Virtual host overlap on Port 80, the first has precedence

where to look?

On 7.10 it’s at /etc/httpd/vhosts/default

?? there is no /etc/httpd on 6.10 as there is in RH variants.
The /etc/apache2/vhosts only contains files from an old ISPconfig installation that got complelety screwed by an automatic Ubuntu update. I’ve been working around it ever since.

Maybe I should just apt-get remove and reinstall apache2?

I found ISPconfig more trouble than entering sites thru Webmin.

A, because somehow I began specifying port 80
B, because I’m an overworked twit who didn’t notice.

<VirtualServerName *> not <VirtualServerName *:80>

apache2 gets it’s LISTEN from /etc/apache2/ports.conf so you don’t specify :80:443 on individual sites.

My bad…

Sounds like you also may be  missing a NameVirtualHost directive :smile:

You should buy a mac server :smile: Less Hassle and yeah, :smile:

:unamused: :unamused:

Um, Mac OS X uses the same Apache as Linux.  Same files, same config, same thing. 

yeah, thats actually the one. I’m too tired to think. Too busy at work.
Hey I managed to get a Band Manager, a Telus Project Manager, and a Network BC guy in Victoria all coordinated and on the same page on a Friday afternoon. If that ain’t a miracle, my parents names aren’t Joseph and Mary!

Sorry inside joke. They really are.
And if you have to ask, my Dad woulda told you “Eh! We’re Italian, not frikkin Peurto Rican!”

Telus is the one provider we dont use and man am I glad for it. Though I hear they may become our tertiary connection :frowning:

Just add a NameVirtualHost :80

There may be no :80 its been a while since i’ve worked with apache. All I do now is er nm im not allowed to talk about it yet :wink:

So joel, why are you not allowed to talk about it ?

I’m guessing his company has some type of proprietary technology; the company has forced him to sign a non-disclosure agreement.  He could tell you.  But, then he’d have to kill you. :smile:
Btw, Jason I think jesus mentioned that his name is not Joel.

How much do you want to bet it is joel,  IT IS joel, he just doesn’t want any one knowing it is him.

I don’t know one way or the other Jason.  Anyway I’m perfectly happy if people want to preserve their anonymity here on HTMF.  I would really appreciate it if you didn’t get into an argument with jesus about this. 
Thank you for your anticipated understanding, Jason. :smile:

You are correct I am under a non disclosure agreement.  Once I have completed the product and we launch I’ll be able to talk about it.  In regards to my name, if you want to think its Joel good for you all the power to you.

While we are outing people I would like everyone to know that Jleaman’s real name is Jennifer.

Now you’ve made me curious. :smiley:  If you feel like it I’d be interested to know what the application is when you’re allowed to talk about it. :smile:

I understand it has something to do with turning water into wine…  a whole new approach into distribution. :smiley:

Timeline right now is about 1-2 months ill post a link with full details once its launched :wink:

Thank you, jesus. :smile:

So I did it again. This time on a Fedora machine. Everything goes to the root folder instead of the proper one.
I was using Webmin both times… I guess that’s where the glitch comes from.
Even manually editing the etc/http/conf/httpd.conf to match what’s in the old server doesn’t help.
So I tried a whole apache reinstall (there’s no backup of default like in Unbuntu) and all the yums in the world can’t grab the files from the repository…
curse curse

Don’t use webmin to set up Virtual hosts. And don’t htmf when you’re stir-frying or you end up with a sticky burnt mess