Re: Rogers ready for launch!

Sharp eyed observers around town have noticed that red Rogers truck, covering numerous areas of town, no doubt testing signal strength and seeking for those drop out zones that can frustrate a cel phone user.

The towers are up and activated and testing has been going on over the last couple of weeks.

The Source and Eastwind Emporium have their line up of phones ready for use, a wonderful line up of technical wonders and any number of usage plans ready to tempt the digital user.

The sign in The Source proclaims that Rogers is ready to roll on March12…

( from  the blog a town called podunk,  click on the link below to see the entire article … 5819  )-

The tower on the highway was on today for the first time, I noticed.

Just so I’m clear on how this technology works… Rogers has it’s own network, as does Telus. If I own a Rogers phone, it’s not going to work in area’s where Rogers doesn’t have coverage but Telus does, and vice-versa?

Yeah, Rogers uses GSM, while Telus (and Bell & Citywest) use CDMA.

Most of the world actually uses GSM.  Even in the USA, some carriers are changing over.  GSM is an open standard, CDMA is proprietary.

So no, a Telus phone cannot work on a GSM network.

The good news is that Telus is considering dumping its “betamax” CDMA network in favour of a GSM one:

Too bad Citywest didn’t just go out and buy a few GSM cells itself.

This is excellent news for me. I’ll be heading up there in may and was hoping they’d be ready. It really sucks going from being able to contact people at any time to being out of touch and forced to use a pay phone.

Excellent news for a lot of us. :smile: 
I haven’t decided yet what I’m going to do.  My contract with CityWest expires in late June.  My cel still echoes. :imp:

I think most cell phones have echos.

Hey, that’s great! Now I can use my Fido phone there.

Perhaps.  But, my phone started to echo after they did the switch to the Bell network. 
Good point though, it isn’t a big deal.

I have 3 cellphones that don’t echo.

i also have 3 cells and they dont echo

Mine rarely does, Sometimes I get dropped calls. But I’m fairly happy with Citywest as of late.

Hitest, if your Citywest phone has an echo, bring it in and show them.  They’ll fix it.

Be sure to say “can you hear me now, now, now” when you bring it in though… :smiley:

Okay.  Thanks, MiG.  I’ll do that:-)

Heh-heh.  Good one.  :smile:

Well I and some of my friends attended the Rogers lunch today at Chances.

I now have a Rogers number, and friends from outside of Rupert can call it no problems at all. It also works with Skype. The only problem is that Citywest phones (both landlines and cell) don’t seem to recognize the number. Funny that I can receive phone calls from Vancouver (and from Asia!) but not from Rupert.

It’s a 250-600-xxxx number, which is actually a Port Edward number. Apparently Rogers is using Telus as their exchange, not Citywest.

Citywest probably needs to reprogram their phone equipment to recognize the 600 prefix,  I think.

If it works from outside of Rupert, but doesn’t work from a Citywest phone, then it’s most likely a Citywest programming issue.  I’m sure they’ll fix it soon.

I just tried calling my own 600-xxxx number from a couple of Citywest phones, and they just don’t recognize it.  600-xxxx or 250-600-xxxx or even 1-600-xxxx doesn’t work, period.  I had someone call me from Vancouver and it’s fine, and then I called the number with Skype and it worked as well.

Edit: curiously, you can call from a 600-xxxx number to a CityWest number, but not vice-versa.  Caller ID on the Citywest phone identifies the 600-xxxx number properly too.

The VP of Rogers says its good to be in Rupert.

[original attachment deleted after 2 years]

Hopefully CityWest will address this issue quickly.  Odd indeed.