Website access

I’ve been trying to access the Prince Rupert Port Authority website and have not been able to. Does anyone else have that problem ? How do I fix it ?

I enter into the address bar and get there no problem.

I do that and Google says it can’t find that page ???? This has been going on for awhile.

No problem here either.

I tried the link yesterday after I read the post. It didn’t work for me either.
I Googled ‘Prince Rupert Port Autority’ and none of the sites with that name worked.
I just got ‘Cannot display the page’.
Then I went to Wikepidia and clicked on its link to the port and it worked.
I went back and tried the other links and they were working! Very strange.

I tried that and it still didn’t work…can’t figure it out.

The website doesn’t work for me either. I don’t think this is an isolated occurrence.

not working for me, either.

Works fine for me.

Working fine for me.

Make sure you enter the URL in the address bar instead of searching from Google.

The Google links work okay for me too.

I don’t even have a Google search bar in my FF. I for some reason (even when I had the Google Search in my FF) still went directly to :smile:

not working for me now for some reason.