Slackware 11.0, FreeBSD 6.1 Dual Boot

I’ve just finished setting up my dual boot Slackware 11.0, FreeBSD 6.1 system.
First I re-sized my sda2 root slackware partition. I did this by booting my computer with an Ubuntu 6.06 CD then re-sizing the partition with Gparted which worked flawlessly, creating room for BSD. I then used Gparted to create another partition.
I then booted my BSD install disks and installed FreeBSD 6.1 to the newly created partition. After the install I booted into Slackware and modified my lilo conf, then ran /sbin/lilo

Here’s my liloconf:

Linux bootable partition config begins

image = /boot/vmlinuz
root = /dev/sda2
label = Linux

Linux bootable partition config ends



I can now boot either Slackware or BSD with lilo:-)

Link to larger picture:

[original attachment deleted after 2 years]

I too am capable of amazing feats!

[original attachment deleted after 2 years]

Heh, my set-up was not that amazing, I screwed up a lot getting there:-)
Very cool:-)  One day I’d like to dual boot XP and OS X. :smiley:

I just downloaded the intel version of osx. Im really wanting to try it in a Dual zeon Dell Workstation. Hope it all works…

Cool.  That sounds like fun, man! :smiley:

Well if it doenst ill convert the dual zeon box to linux :smile:

lilo? that was so 2002…

I don’t even remember how to write a lilo.conf file anymore!

Yeah, Slackware is a bit old-school:-)  I kind of like lilo though.  GRUB is a great bootloader too. :smiley:

I think those crazy coders are beyond grub now too… I saw a screenshot the other day of one that had ICONS! And a menu system! Too nuts for me…

An icon bootloader with a menu system?  Would you care to elaborate please?  That sounds cool, I haven’t heard of this one.
Are you talking about some type of graphical installer? :smiley:

It was on Freshmeat about a week ago, I took a looky at the screenshot. Had a solid > 1.0 version number too and had native support for lots of OSes.

Right!  I have heard about GAG, that looks very cool :smiley:  Interesting.  I haven’t tried that one:-)