Redirects out of thread


#1

Tried to read the thread about Overwaitea changing to SaveOn but it flashes on the screen then goes back to the main list. Several other threads do the same.
I can read and did post about gas prices in the Prince Rupert thread today though. Wassup?


#2

Any chance you can record this happening? (ie: do a screen recording?)


#3

Works fine here over in my neck if the woods


#4

I had the same problem as Herbie last night. No other threads - at least the couple that I went to - were affected. I left HTMF and came back a few minutes later and all was well. Weird glitch.


#5

If it happens again, can you try to record the screen somehow?

If you’re on a Mac, you can do it with Quicktime.

If you’re on a recent version of Windows, you can use VLC to record your screen.

I would love to track down what’s happening when you’re getting redirected.


#6

Interesting. This isn’t happening to me yet. It may be because I run Linux. Thanks for the tip about VLC, MiG. VLC does the screen capture thing in Slackware Linux as well. I suspect other versions of Linux will work too.


#7

Well it started happening to me as well, on a couple of different threads. So I tried to do a screen recording but then it worked again.

This was on Firefox, BTW. What browsers are you guys using?

Might have something to do with how Cloudflare is caching the site. I’ll take a look at the settings.


#8

Running Chrome here.


#9

Ok, I was able to catch it again.

Didn’t happen in Chrome or Safari, just in Firefox. Gonna try and figure it out.


#10

Ok, I think I may have found the issue.

Let me know if it happens again?

I’ve been able to reproduce it only in Firefox (both Windows 10 & Mac OS X), but not in other browsers. I had some code that decided whether to show you Google Ads or not depending on your membership level, and depending on the posts (it would show an ad in the middle of the posts).

Turning that seems to fix the issue.

Fingers crossed.

@herbie_popnecker and @DWhite were you using Firefox? Let me know if you see it happening again.


#11

I also use chrome with no issue so far


#12

It works fine today.
I use Firefox on both the PC and Mac, and noticed some wierdness on other sites with ads too. On Gasbuddy, the video ads sometimes open an empty frame or even just a frame maybe 20px wide and the video never loads.
The odd time it would just crash the browser completely.
AW GEE guess I’ll need to dump Firefox so I can see all those ads, eh? NOT


#13

Well hopefully that change I made with the ad stuff will fix it.


#14

I use firefox. When I first posted, I had only had trouble with the one thread (Overwaitea). Earlier today, I couldn’t get into any thread except Ironically, Herbie’s thread on gas prices. All seems fine at the moment.


#15

Yup, I was able to recreate the behaviour, and it was only Firefox, on Windows, Mac OS X, Linux, etc.

But it only happened when the ‘in thread’ ad code was inserted. Once that was disabled, it seemed to go away. So that’s an easy solution.

Thanks for bringing this up :hamburger: