Older ibook g4 will not boot

-couldn’t empty the trash, kept getting an error 50 (unknown error). 
-iBook was shut down
-restart after a little while
-Apple logo appears, not picking up any systems
-Tried without the battery on plug alone,  no success
-Tried resetting the PRAM, no success
-Tried booting from diskdrive with OS X disk, no success.

I will bring it to a tech this week but any advice, help would be great.

When you put in OS X disk, did you hold the C key while booting?

Do you have another Mac OS X computer and a Firewire cable?

So I should try connecting through the other one (like an external hard drive)?

Yes, try that.  Hold T while booting up and it will go into Target Disk Mode.  Then connect it to the other Mac using the Firewire cable and see if it shows up on the desktop.

If it doesn’t, fire up Disk Utility and see if it shows up in there. 

The computer is more than 5 years old, the hard drive may have failed. 

Will it work with usb? I can’t find the firewire ( if I have one)

The computer is 4 years old.

No, you need a Firewire cable for Target Mode.

Try holding Apple-V while turning it on (and hold it until it tries to boot) and see if any errors show up.

Gonna have to do this later.  I can’t find the firewire.

I will try Apple-v now

In terminal mode right now:

lots of stuff but the following seems to be a key message:

couldn’t find root user.  Sleeping and trying again

This keeps repeating in between a strings of “hfs_swap_BTnode : invalide forward link…” 

Edit:  Can I shut it down using the button right now?  It keeps doing the same thing over and over again?

Good, that means the drive isn’t dead.  That’s if it’s booting from the hard drive.  Try again with the CD/DVD out.

Next step is single user mode.  Do the same thing, this time with Apple-S instead of Apple-V. 

If you get a command prompt, try typing

/sbin/fsck -fy