7/11 speakout on iPhone

Well I certainly learned something new. I had no idea there was a site that would just do the config for you. When I did it to our two phones I did it all manually. Not that it’s hard, but that site sure speeds it up.

Mig you should do a how to for VPN I got my iPhone working with it over wifi but it will not connect through 3G , I’m using dd-wrt on linksys 350n was going to try it on my linksys 3000 but will Waite… Thanks

Can you please post the VPN settings?


It gets a bit complex :smile: I personally use a Cisco client with a university VPN. It runs on port 443, which isn’t blocked by SpeakOut since that’s the port used for SSL – encrypted websites.

If your phone is jailbroken, you can use this: guizmovpn.com/ Or if you’re good with unix, you can just install openVPN from a command-line shell.

There are numerous free OpenVPN providers. OpenVPN also runs on port 443. Before switching to the Cisco client and the university VPN account, I was using OpenVPN for free from these guys: vpnbook.com/

Honestly, unless you have a real need for this, I wouldn’t bother with a VPN. Just enjoy the limitations on the $10/unlimited plan. It takes a lot to set up a VPN properly, then you gotta remember to turn it on and off, or have your battery drain really fast, etc.

MiG, I read your comments about using a VPN to bypass SpeakOut port restrictions: something I’ve been attempting fruitlessly for a long time. You made the comment that you were met with previous success using vpnbook, and given that OpenVPN has recently released a long-awaited app for the iPhone (itunes.apple.com/ca/app/openvpn … 79981?mt=8), I thought it might be possible to make use of this app along with the service provided by vpnbook.

Using the link you provided, I downloaded the profile for the OpenVPN Certificate: (TCP Port 443) and loaded the certificate information into the app, entering the username “freeopenvpn” and the password “J8hfCiu6W” as provided. This worked seamlessly over wifi, connecting me to the VPN network and allowing me access to the internet as normal. However, whenever I try to replicate this process over SpeakOut data, it gets stuck on the “waiting for server” phase, and eventually times out after about 25 seconds.

In an attempt to remove redundancies, I adjusted the SpeakOut profile for my iPhone by removing the username (wapuser1), password (wap), and server and port ( Even after loading this modified profile with blank fields, a connection was not established with the same timeout error appearing. I even tried to connect with no configuration profile on my iPhone, but this too was fruitless.

I would greatly appreciate it if you could provide me with pointers or suggestions on how to troubleshoot and/or solve this problem. Thank you for your consideration.

Hi there,

I just tried, and was able to get OpenVPN working on SpeakOut using the following:

  • NOT using the APN or any APN settings at all. If you’ve installed the APN profile, delete it.
  • using my personal OpenVPN server (port 443 TCP), by importing the .openvpn and certificates using iTunes
  • using Private Tunner – a free service. Address https://www.privatetunnel.com/index.php?referral=CM5SZSYOZK (refer friends for more data, just like I did there)

When I get time (perhaps tonight), I’ll update the tutorials and create a new one on using OpenVPN.

Thanks for pointing out the OpenVPN app.

It’s weird, 'cause the privatetunnel connection uses UDP port 1194, as you can see below, while my personal OpenVPN server uses TCP 443. They both seem to work fine.

Does OpenVPN go to sleep after a period and allow apps to “push” data unencrypted? Something to check. Apple did this with there included IOS VPN default software.

So far it hasn’t, but I would need to test it out with a longer idle time. I left the phone asleep for 15 minutes, and when I came back, the VPN was still connected.

why not just have all your traffic routed through your home firewall ? like i have mine…

Sonicwall, has a wicked app, or you could use open vpn, for pfsense /untangle/ others.

Initially heartened by your response, I signed up for a Private Tunnel account (using your referral) and uninstalled the APN profile on my phone. However in testing, I was only able to connect over WiFi :frowning: which connected swiftly over UDP port 1194 as you mentioned. Whenever I attempted to connect over 3G without an APN profile installed, it got stuck on the “Looking up DNS name”, and would remain like that until the connection timed out.

Out of a combination of desperation and the slightest vestige of hope, I attempted the same process with the APN profile installed, however the process simply advanced to “Waiting for server” and then got stuck there instead, remaining like that until the connection timed out as before. I even tried playing with the OpenVPN settings located as a sub-menu of the main settings app, however despite forcing it to use TCP (which connected on port 443 using wifi) instead of the default UDP connection, I was still not able to connect over 3G. I also adjusted the Connection timeout setting to 2 minutes, but to no avail.

I would greatly appreciate your continued insights into the nature of what I can attempt as a solution. Your success has whetted my appetite for what I perceive to be the Holy Grail of the SpeakOut plan!

Oh, and the other thing I forgot to ask, you mentioned “the tutorials”. Can you please point me in the direction of where I can find these? Thanks :smile:

So, after a lot of experimenting, I found a strange combination of settings that managed to connect. By keeping the SpeakOut APN profile installed, and also adding proxy settings to the OpenVPN app as shown below, Private Tunnel was able to connect successfully over data. Images now appear uncompressed, and I can download apps over data, but iMessage still fails to send. I’m not quite sure how what I’ve set up is working, but I thought I’d post it just in case anyone’s interested :smile:

Well, I’ve been experimenting for some time with the OpenVPN app.

I’ve tried 3 different SIMs, and you’re right – some needed different settings than others. One (my main number), I removed the APN settings and it worked. On other, I had to put the proxy settings into the OpenVPN configuration file to get it to work properly.

Meanwhile, to answer Dex’s question: now only does the OpenVPN connection remain, but it even switches over gracefully from WiFi to 3G and vice-versa. I’ve done about 2 gigs of data through the OpenVPN connection. Very nice so far.

Another followup. I now have two iPhones on SpeakOut. Same area code, same exchange. In fact, only the last digit of each phone number is different.

But here’s where it gets weird. Both phones use the same OpenVPN client, same .opvn config, same server (a VPS in the US).

For SIM1, the OpenVPN app would only work without the SpeakOut APN.

For SIM2, the OpenVPN app would only work with the SpeakOut APN, and the proxy settings as you have above, Jeremy.

From what I can tell, it’s all a bit random. But the data restrictions are tied to the SIM for sure, because swapping phones, putting them in an Android phone, etc, all didn’t make a difference.

But that’s ok. For $10/month for unlimited use, I’ll settle for just the browsing and most apps working. Having OpenVPN work is a bonus. I don’t want to abuse it or go overboard. It’s Canada’s cheapest mobile data plan, and I’d hate to see them change it.

Hi, i have created and installed the speakout apn, how do i actually use it to access the net if i’m out and about without a wireless hotspot to connect to. do I have to select something on my iphone 3gs? thanks Gary

Did you activate the unlimited web browsing add on with your account? You can do that online or by calling 611.