Slow internet


#1

My internet is slow. Like really slow. So is it my modem or my provider? How do I tell? TIA


#2

Mine has been a bit slower lately also. Pay for 20m/b package from Citywest and from the speed tests I have been running lately defiantly not impressed.


#3

http://www.speedtest.net/result/3802669772.png

Test done at 11:27 PM on Wednesday October 1st. I pay for 20 meg.


#4

last few weeks it has been slower most days at night, sometimes I do a tracert and the hop out of town is where it slows right down. i normally do the speed test or tracert to the terrace office of CityWest


#5

sooo is it my modem or city west?


#6

What is your package that you are paying for SPEED WISE.


#7

http://www.speedtest.net/result/3804936742.png


#8

Are you using Wifi? OR are you plugged directly into the back of the modem?

If you are using wifi, how many other devices are using it at the same time?

And last but not least, have you tried turning it off and then back on again?

250-624-2111 The techs at night are usually pretty good.


#9

Doing a speed test within town does not help, do the speed test to servers outside of town, I did a tracery to a Chicago gaming site and the route went down to Denver before heading to Chicago normally goes through Toronto, also the hop to terrace was 60 ping instead of 10 ping so the speed outside of Rupert is slow


#10


#11

I miss owning my own ISP. Six blocks from the central office here, best Telus can do is 5 Mb down. 6 on my iPhone4S
My sister in Truro NS gets 35 up and down, that’s faster than the $4000 a month data circuit we used to have in my office.


#12

http://www.speedtest.net/result/3807692686.png

Yeah, still getting wicked speeds.
Like I said, call the tech line… They can make sure your modem is working properly.
You still haven’t answered any of my other questions…


#13

The Internet here blows !!!


#14

most the time i cant complain, but lately at night it has been shit.

I just did this test, 6.56pm 10/4/14, i pay for the 10meg

http://www.speedtest.net/result/3809270523.png


#15

After a re-start of your modem you can look at other things. For example, if you have a really cheap switch and/or wireless router that can be a bottleneck with your connectivity.


#16

I pay for 20 meg and find in the evenings it really drops rest of the time fairly good


#17

SpeedTest Mexico to Rupert. Not too bad for down here.


#18

[quote=“bubbasteve735”]Are you using Wifi? OR are you plugged directly into the back of the modem?

If you are using wifi, how many other devices are using it at the same time?

And last but not least, have you tried turning it off and then back on again?

250-624-2111 The techs at night are usually pretty good.[/quote]

sorry I was out of town.
I am using wifi, 2 devices, laptop and iPad.
I unplug my modem a few times a day. Lots of times my device will show an internet connection but there isn’t one at all. Unplugging it fixes the problem but I have to do it regularly.


#19

I actually don’t know what speed I am paying for, most likely the basic one but still it should be faster.
Maybe I need to replace my modem.

Thanks for the responses


#20

Your issues sound really similar to ones I was having last year. I was using around 8 year old wireless router. I bought a new dual-band one cheap at last year’s boxing day sales, and performance is much improved.