Setup Wireless Router Help ASAP!?!?!?

I am SOOOO tired of scamming internet from Burger King.  Could somebody please help me with this here problem right quick, it is very frustrating!

Seriously problem here, bought a wireless router (from SMC) and was trying to get it setup.  It worked and all three laptops got internet.  Now it’s broke and I’ll tell you what we did:

After successfully using the internet we wanted to make the WiFi secure so that other jerkasses in the building couldn’t scam us.  We then connected to the router via, logged in with the default password and then started going to town:

The VERY last thing we did before the internet went caput was playing with the Security Wireless Encryption…  This was the chain of commands:


And here we changed it from Open to “WAP/WAP2 Only”

Now, we can receive a wireless signal but no internet comes from it.  The WiFi is broadcasting and there’s a little Lock picture next to the name, but none of us can connect directly to it (I’m on a Mac and when I connect with the wrong password it still shows me as being on that WiFi.  The others on PC can’t do a thing).

Now, we can’t communicate with the Router… it says that the router has no IP.

We tried reinstalling the software but it says something along these lines “The Adapter does not correspond with the Wireless Router’s IP.  Please disconnect power from the Router for 30 seconds and restart the wizzard.”

We have done that many times, all to no avail.

What the frick-dang-fuck is going on???

Is there any way to reset a router?  I don’t see any buttons??!?

It is a 54Mbps wireless router from


I Would Like Some WiFi!

I don’t know exactly how I did it but it’s done.  No help required.