BitTorrent and local IP banning

HI all I have been having problems with torrents as of late I have talked to others in Prince Rupert who are having the same problem. Let me explain I have full adsl 3 IP’s my average download speed is 16 kbs this is with a file that has over 400 seeds and 23000 peers. but im only logging on to a few seeds and peers. It does not matter what client I use I have tried them all I have also opened my half-open tcp limit to full limit 50 from 10.
My computer that did the downloads was on ip 209.blaa.blaa.98 it was fast but started top slow so I changed to ip 209.blaa.blaa.100 and it was fast for a few months. Im going right from the computer to the switch then to the modem. today I try 209.blaa.blaa, 99 and what do you know Im super fast again i connected to 15 seeds and 30 peers and was downing at 140 kbs.

so I take that computer and plug it right in to the modem, 99 fast 100, and 98 are shit same file same computer nothing changed except the ip. I go back to 99 and i again connected to the same amount of seeds and peers with the same download speeds.

I went to citytel this morning and talked Greg he was a great help… he could not explain why those ip using the same torrents on the same computer could not connect. he sugested those IP could be banned… I usualy dont go to sites that have ratio’s.
I have test my speeds with all 3 ip’s and I get 1.5 megs to 2 megs download speed depending were I test to…

its strange one ip can connect the other two cant using the same computer.


Possibly you’re using a slightly outdated client with a bug, which other clients are blacklisting?

its the same machine, same software different IP ,Im using bitspirit, and bitTordano

From what I’ve heard/read, ABC and Azereus are still the ‘best’ torrent clients out there. Try making the switch just to see what happens. I use Azereus myself.

its not the clients its the ip’s erg

I use azureus, and I’ve noticed that if you throttle your upload rate, the download rate starts to suffer as well.

Also, torrents are very variable in their rates. Sometimes they are fast, sometimes they are slow. There are way too many variables (bandwidth from all the seeds and peers, and the effective throughput from them to you, etc) to accurately predict a certain download rate.

Does Citytel still do packet shaping?

all i did guys was swich Ip numbers and it runs better…same computer same torrent software, same torrent all thats different is the IP numbers, i can not connect to seeds or peers under 2 ips the 3 ip I can download crazy…

What else do you run on your other IPs?

Is the traffic on all three IPs the same?

Any reason your IP could be blacklisted?

Are you using a router?

Try something other than bittorrent to gauge the bandwidth, though, 'cause there’s just no way to get an accurate reading with so many variables. I mean, if one of the seeds all of a sudden starts to use his connection for something else, then your effective torrent throughput goes down, and it wasn’t because of anything you did.

Approach this scientifically, rule out what it could be, etc. But use something other than bittorrent. Like try downloading a big file from a website on one IP, change IPs, download the same file (clear cache, etc), and see if there’s a difference.

Right now I’m downloading a torrent at 120kB/sec. 5 minutes ago it was at 40kB/sec. Before that, it was at 180kB/sec.

download the latest azureus, make sure you’re in advanced mode. enable transport encryption under connection in the options.

voila, citywest and or telus can’t do a thing about it now. i had the same problem as you starting a long time ago.

hi mig when i did the test it was from computer right to modem there was no other software no other program running i could see seeds 3oo, but only connect to one with the peers were like 2300o but i could only connect to 3

i test my adsl speed with all 3 ips they range up to 2 megs at asdl at

i dont use the as i have a server its connected to I did how ever unplug it and tried it in a other computer and again same software same torrent got better speeds then and 98

I just tried with Azureus and nothing Yes I know to wait abit but 5 days to download a 600 meg file with 300 seeds and 2300 peers is a bit much also I can not connect to more then one file at at a time on those IP 100 and 98 but on 99 I can connected to more then one file… I have been using bittorrents awhile so I know its a problem with IP’s not software, computer, clients and such…
when I did the test’s the computer was directly to the modem

I do have a switch that goes to my D link router but again it does not matter as before it all worked fine its been the last few months I have noticed differences in download speeds and a few freinds have noticed the same thing…

Did you open ports on the router? Or are you testing directly connected?

Perhaps your IP is blacklisted on some trackers (which is weird) – that would explain why you can only connect to some seeds and peers. That would also explain why the overall rate is low.

It’s not like you’re connecting to a bunch of seeds and peers and it is still slow, is it? Is the problem that you can’t connect to the seeds and peers in the first place?

It doesn’t seem to be a bandwidth thing at all, but rather a connection problem. You’re only connecting to a few seeds or peers, so you can’t expect to have a good transfer rate.

You don’t have any weird firewalling going on? And the router is forwarding the ports properly?

no im connected directly i download from
also Mig its says there are 300 seeds available but i can only connect to a few of them. i think i have been blacklisted for using bitspirit as it was great for bypassing sites that u had to sighn up…

enable transport encryption in azureus, it isn’t enabled by default. like i said earlier, i had the exact same problem, i wasn’t the only one with this problem either.

no difference dude… but then again i knew that

Well, that’s it then :wink:

If there are 300 seeds on the torrent (and I’d say a hell of a lot more peers), and you can only connect to a few, then there’s something wrong for sure. But it isn’t a bandwidth issue (and not a CityWest issue either, I wouldn’t think).

When you use Azureus, it has a little count on the bottom that keeps track of banned IPs and stuff…

Try downloading something from a public torrent site, one that doesn’t have warez and stuff. I’ll bet you’ll get great speeds.

Nate – The problem with encryption is that unless you specify non-encrypted fall-back, you’ll only be able to connect to peers that are also using encryption. And if you’re using non-encrypted fall-back, then there’s no difference between that and not using encryption. It’s the chicken-and-egg thing.

Astrothug: Try this:

Grab that torrent and see how fast it goes. It on a clean tracker, no warez or crap. You shouldn’t be banned there. I just started it 2 minutes and I’m connected to 80 seeds and getting 242kB/sec (which is pretty close to the limit on my connection).

everything you are explaining was exactly what i was going through. it has nothing to do with router settings, firewalls, bit torrent clients or trackers. if so then why don’t you have a problem downloading when all you change is an ip?

all i can say is that encrypting the activity fixed the problem for me and many other people.

edit: i figured that didnt need mentioning MiG, it’s kind of hard to miss when you go to enable the encryption.

If changing your IP fixes things, that would suggest a problem with the IP.

Now either the IP is being blocked or filtered by CityWest, or the IP has been banned by the tracker you’re trying to use. Either way, changing the IP would fix either of these problems, right?

So try downloading the torrent I linked to up there.

If that torrent works fine, then the problem isn’t CityWest (and not encryption). The problem is that your IP is blacklisted on some torrent trackers.

If that torrent doesn’t work for you, then you’ve ruled out that possibility.

I’m downloading this torrent right now, and out of 80 connections, only 3 are encrypted. And their speed sucks.

I doubt encryption is his problem, he’s not being bandwidth-choked or shaped or anything. He’s just not being allowed to connect to certain trackers.

There is absolutely no harm in turning on encryption, though, just keep the unencrypted fall-back stuff on too. But he’s already said that it didn’t make a difference when he turned it on:

hi mig that file on ip 100 is getting 200 kbs right now

ok im getting 400 kbs…ok 15 min to download